Резервирование L3 с HSRP на коммутаторах Cisco

Main

Оценка: 100% - 3 Голосов

Общая

Небольшой гайд по настройке резервирования L3 на коммутаторах Cisco с использованием HSRP.

Используется следующее оборудование:

  • 2 коммутатора Cisco 4900M (с оптическими модулями) с именами sw3-00-0 и sw3-00-1. Данные коммутаторы будут выступать в качестве ядра сети;
  • 2 коммутатора Cisco 4948E-F с именами sw3-01 и sw3-11. Данные коммутаторы будут выступать на уровне распределения;
  • 3 коммутатора Cisco 4948E-F с именами sw3-02, sw3-03 и sw3-04. Данные коммутаторы будут выступать на уровне доступа для оконечных пользователей.

 Топология подключения:

View the embedded image gallery online at:
https://itcrowd.top/hsrp-switch-l3#sigProIdca5c51fbf5

 

В примере конфигурации будет 2 VLAN:

  • VLAN 129 с именем Network и параметрами 192.168.129.0/24. В данной сети будут находиться сетевые устройства и коммутаторы;
  • VLAN 144 с именем Users и параметрами 192.168.144.0/24. В данной сети будут находиться пользователи.

Адресация:

  • Адрес sw3-00-0 в VLAN 129: 192.168.129.251;
  • Адрес sw3-00-0 в VLAN 144: 192.168.144.251;
  • Адрес sw3-00-2 в VLAN 129: 192.168.129.252;
  • Адрес sw3-00-2 в VLAN 144: 192.168.144.252;
  • Адрес sw3-01 в VLAN 129: 192.168.129.131;
  • Адрес sw3-11 в VLAN 129: 192.168.129.141;
  • Адрес sw3-02 в VLAN 129: 192.168.129.132;
  • Адрес sw3-03 в VLAN 129: 192.168.129.133;
  • Адрес sw3-04 в VLAN 129: 192.168.129.134.

Шлюзом для каждой сети будет выступать виртуальный адрес с окончанием на 254 (xxx.xxx.xxx.254).

Протоколом маршрутизации выбран OSPF.

HSRP будет использоваться с авторизацией.

 

Полный конфиг для загрузки в формате TXT.

 

Уровень ядра

Настраиваем sw3-00-0

Настраиваем RSTP:

spanning-tree mode rapid-pvst

 

Создаем ключ для авторизации с наименованием hsrp_key:

key chain hsrp_key
key 10
key-string 0 12345

 

Прописываем VLAN и их имена:

vlan 129
name Network
exit
!
vlan 144
name Users

 

Создаем каждому VLAN интерфейсы, с указанием группы и standby IP xxx.xxx.xxx.254:

interface Vlan129
ip address 192.168.129.251 255.255.255.0
standby version 2
standby 1 ip 192.168.129.254
standby 1 priority 120
standby 1 preempt delay minimum 300
standby 1 authentication md5 key-chain hsrp_key
no sh
exit
!
interface Vlan144
ip address 192.168.144.251 255.255.255.0
standby version 2
standby 2 ip 192.168.144.254
standby 2 priority 120
standby 2 preempt delay minimum 300
standby 2 authentication md5 key-chain hsrp_key
no sh
exit

 

Настраиваем OSPF:

router ospf 1
router-id 192.168.129.251
network 192.168.129.251 0.0.0.0 area 0
network 192.168.144.251 0.0.0.0 area 0

 

Назначаем VLAN на нужные интерфейсы:

interface TenGigabitEthernet3/3
description to sw3-11 Te1/52
switchport trunk allowed vlan 129,144
switchport mode trunk
no cdp enable
no sh
exit
!
interface TenGigabitEthernet3/4
description to sw3-01 Te1/52
switchport trunk allowed vlan 129,144
switchport mode trunk
no cdp enable
no sh
exit
!
interface TenGigabitEthernet3/8
description to sw3-00-1 Te3/8
switchport trunk allowed vlan 129,144
switchport mode trunk
no cdp enable
no sh
exit

 

 

Настраиваем sw3-00-1

Настраиваем RSTP:

spanning-tree mode rapid-pvst

 

Создаем ключ для авторизации с наименованием hsrp_key:

key chain hsrp_key
key 10
key-string 0 12345

 

Прописываем VLAN и их имена:

vlan 129
name Network
exit
!
vlan 144
name Users

 

Создаем каждому VLAN интерфейсы, с указанием группы и standby IP xxx.xxx.xxx.254:

interface Vlan129
ip address 192.168.129.252 255.255.255.0
standby version 2
standby 1 ip 192.168.129.254
standby 1 priority 110
standby 1 preempt delay minimum 300
standby 1 authentication md5 key-chain hsrp_key
no sh
exit
!
interface Vlan144
ip address 192.168.144.252 255.255.255.0
standby version 2
standby 2 ip 192.168.144.254
standby 2 priority 110
standby 2 preempt delay minimum 300
standby 2 authentication md5 key-chain hsrp_key
no sh
exit

 

Настраиваем OSPF:

router ospf 1
router-id 192.168.129.252
network 192.168.129.252 0.0.0.0 area 0
network 192.168.144.252 0.0.0.0 area 0

 

Назначаем VLAN на нужные интерфейсы:

interface TenGigabitEthernet3/3
description to sw3-11 Te1/51
switchport trunk allowed vlan 129,144
switchport mode trunk
no cdp enable
no sh
exit
!
interface TenGigabitEthernet3/4
description to sw3-01 Te1/51
switchport trunk allowed vlan 129,144
switchport mode trunk
no cdp enable
no sh
exit
!
interface TenGigabitEthernet3/8
description to sw3-00-0 Te3/8
switchport trunk allowed vlan 129,144
switchport mode trunk
no cdp enable
no sh
exit

 

Проверка работы HSRP

Проверить работу HSRP и узнать какорй коммутатор активный в данный момент можно командой:

show standby

 

Проверить RPVST и понять какие порты в каком режиме:

show spanning-tree

 

 

Уровень распределения

На данном уровне уже не будет использоваться HSRP поэтому настройка короче.

 

Настраиваем sw3-01

Настраиваем RSTP:

spanning-tree mode rapid-pvst

 

Прописываем VLAN и их имена:

vlan 129
name Network
exit
!
vlan 144
name Users

 

Создаем каждому VLAN интерфейс:

interface Vlan129
ip address 192.168.129.131 255.255.255.0
no sh

 

Настраиваем OSPF:

router ospf 1
router-id 192.168.129.131
network 192.168.129.131 0.0.0.0 area 0

 

Назначаем VLAN на нужные интерфейсы:

interface TenGigabitEthernet1/49
description to sw3-02 Te1/52
switchport trunk allowed vlan 129,144
switchport mode trunk
no cdp enable
no sh
exit
!
interface TenGigabitEthernet1/50
description to sw3-11 Te1/50
switchport trunk allowed vlan 129,144
switchport mode trunk
no cdp enable
no sh
exit
!
interface TenGigabitEthernet1/51
description to sw3-00-1 Te3/4
switchport trunk allowed vlan 129,144
switchport mode trunk
no cdp enable
no sh
exit
!
interface TenGigabitEthernet1/52
description to sw3-00-0 Te3/4
switchport trunk allowed vlan 129,144
switchport mode trunk
no cdp enable
no sh
exit

 

 

Настраиваем sw3-11

Настраиваем RSTP:

spanning-tree mode rapid-pvst

 

Прописываем VLAN и их имена:

vlan 129
name Network
exit
!
vlan 144
name Users

 

Создаем каждому VLAN интерфейс:

interface Vlan129
ip address 192.168.129.141 255.255.255.0
no sh

 

Настраиваем OSPF

router ospf 1
router-id 192.168.129.141
network 192.168.129.141 0.0.0.0 area 0

 

Назначаем VLAN на нужные интерфейсы:

interface TenGigabitEthernet1/49
description to sw3-04 Te1/51
switchport trunk allowed vlan 129,144
switchport mode trunk
no cdp enable
no sh
exit
!
interface TenGigabitEthernet1/50
description to sw3-01 Te1/50
switchport trunk allowed vlan 129,144
switchport mode trunk
no cdp enable
no sh
exit
!
interface TenGigabitEthernet1/51
description to sw3-00-1 Te3/3
switchport trunk allowed vlan 129,144
switchport mode trunk
no cdp enable
no sh
exit
!
interface TenGigabitEthernet1/52
description to sw3-00-0 Te3/3
switchport trunk allowed vlan 129,144
switchport mode trunk
no cdp enable
no sh
exit

 

Уровень доступа

Настраиваем sw3-02

Настраиваем RSTP:

spanning-tree mode rapid-pvst
spanning-tree portfast edge bpduguard default

 

Прописываем VLAN и их имена:

vlan 129
name Network
exit
!
vlan 144
name Users

 

Создаем каждому VLAN интерфейс:

interface Vlan129
ip address 192.168.129.132 255.255.255.0
no sh

 

Настраиваем OSPF:

router ospf 1
router-id 192.168.129.132
network 192.168.129.132 0.0.0.0 area 0

 

Назначаем VLAN на нужные интерфейсы:

interface TenGigabitEthernet1/51
switchport trunk allowed vlan 129,144
switchport mode trunk
no cdp enable
no sh
exit
!
interface TenGigabitEthernet1/52
switchport trunk allowed vlan 129,144
switchport mode trunk
no cdp enable
no sh
exit

 

Прописываем порты доступа к конечному пользователю, пример на первые 2 порта:

interface GigabitEthernet1/1
switchport access vlan 144
no cdp enable
spanning-tree portfast edge
no sh
exit
!
interface GigabitEthernet1/2
switchport access vlan 144
no cdp enable
spanning-tree portfast edge
no sh
exit

 

Настраиваем sw3-03

Настраиваем RSTP:

spanning-tree mode rapid-pvst
spanning-tree portfast edge bpduguard default

 

Прописываем VLAN и их имена:

vlan 129
name Network
exit
!
vlan 144
name Users

 

Создаем каждому VLAN интерфейс:

interface Vlan129
ip address 192.168.129.133 255.255.255.0
no sh

 

Настраиваем OSPF:

router ospf 1
router-id 192.168.129.133
network 192.168.129.133 0.0.0.0 area 0

 

Назначаем VLANы на нужные интерфейсы:

interface TenGigabitEthernet1/51
description to sw3-04 Te1/52
switchport trunk allowed vlan 129,144
switchport mode trunk
no sh
exit
!
interface TenGigabitEthernet1/52
description to sw3-02 Te1/51
switchport trunk allowed vlan 129,144
switchport mode trunk
no cdp enable
no sh
exit

 

Прописываем порты доступа к конечному пользователю, пример на первые 2 порта:

interface GigabitEthernet1/1
switchport access vlan 144
no cdp enable
spanning-tree portfast edge
no sh
exit
!
interface GigabitEthernet1/2
switchport access vlan 144
no cdp enable
spanning-tree portfast edge
no sh
exit

 

Настраиваем sw3-04

Настраиваем RSTP:

spanning-tree mode rapid-pvst
spanning-tree portfast edge bpduguard default

 

Прописываем VLAN и их имена:

vlan 129
name Network
exit
!
vlan 144
name Users

 

Создаем каждому VLAN интерфейс:

interface Vlan129
ip address 192.168.129.134 255.255.255.0
no sh

 

Настраиваем OSPF:

router ospf 1
router-id 192.168.129.134
network 192.168.129.134 0.0.0.0 area 0

 

Назначаем VLAN на нужные интерфейсы:

interface TenGigabitEthernet1/51
description to sw3-11 Te1/49
switchport trunk allowed vlan 129,144
switchport mode trunk
no sh
exit
!
interface TenGigabitEthernet1/52
description to sw3-03 Te1/51
switchport trunk allowed vlan 129,144
switchport mode trunk
no cdp enable
no sh
exit

Прописываем порты доступа к конечному пользователю, пример на первые 2 порта:

interface GigabitEthernet1/1
switchport access vlan 144
no cdp enable
spanning-tree portfast edge
no sh
exit
!
interface GigabitEthernet1/2
switchport access vlan 144
no cdp enable
spanning-tree portfast edge
no sh
exit

 

По окончанию настройки можно подключить пользовательское устройство в настроеный порт на уровен доступа и для тестов сымитировать аварию нектоорых коммутаторов и проверить доступ к шлюзу по умаолчанию для сети.

  • Просмотров: 214
Добавить комментарий