Пример настройки HSRP протокола.

HSRP (Hot Standby Router Protocol) - проприетарный протокол Cisco, предназначенный для увеличения доступности маршрутизаторов выполняющих роль шлюза по умолчанию. Это достигается путём объединения маршрутизаторов в standby группу и назначения им общего IP-адреса, который и будет использоваться как шлюз по умолчанию.

Версии протокола

Существуют две версии протокола HSRPv1 и HSRPv2 которые не совместимы друг с другом по причине разного формата пакетов.
Так же основным отличаем протоколов является количество доступных номеров групп HSRP - у первой версии номера групп могут быть от 0 до 255 тогда как вторая версия помимо расширенного количества номеров групп, от 0 до 4095, может использовать диапазон MAC-адресов от 0000.0C9F.F000 до 0000.0C9F.FFFF. Так же данные протоколы используют разные мультикаст-адреса: 224.0.0.2 у первой версии в связи с чем данный протокол нельзя использовать с Cisco Group Management Protocol (CGMP - протокол управлениея мультикастом в локальной сети) и 224.0.0.102 у второй версии протокола, допустимый к использованию с CGMP.

Основные понятия протокола HSRP

  • Active Router — активный маршрутизатор на данный момент;
  • Standby Router — маршрутизатор в режиме резерва. Ожидает отказа Active Router. Состоит в той же HSRP группе, что и активный;
  • HSRP группа — группа маршрутизаторов, участвующих в одном и том же резервировании, образуя виртуальный маршрутизатор. На одном физическом маршрутизаторе можно использовать несколько разных групп;
  • Priority — величина, определяющая активный маршрутизатор и имеющее значение по умолчанию равное 100. Может иметь значение от 1 до 255;
  • Аутентификация — пароль для доступа к HSRP группе и указывается на всех маршрутизаторах группы. Пароль передаётся в открытом (не зашифрованном) виде. Не обязателен;
  • Hellotime - таймер ожидания hello пакета от активного маршрутизатора. Заедается в интервале от 1 до 255. Значение по умолчанию 3;
  • Holdtime - таймер определения отказа активного маршрутизатора. Заедается в интервале от 1 до 255. Значение по умолчанию 10. Значение Holdtime устанавливается равным трём значениям Hellotime;

Команды настройки HSRP

  • standby номер_группы ip ip-адрес - указывает адрес ip-адрес виртуального маршрутизатора в указанной группе;
  • standby version версия_протокола - указывает версию протокола 1 или 2;
  • standby номер_группы priority значение_приоритета - указывает приоритет маршрутизатора в указанной группе;
  • standby номер_группы preempt - разрешает перехват функций если приоритет выше чем у активного маршрутизатора;
  • standby номер_группы track имя_интерфейса приоритет - понижает значение приоритета маршрутизатора на указанную величину приоритета если интерфейс недоступен. Значение восстановится если интерфейс станет доступен;
  • standby номер_группы timers hellotime_сек holdtime_сек - задает значение таймеров hellotime и holdtime;
  • standby номер_группы authentication пароль - пароль для доступа к группе.

Пример настройки

В приведённой ниже топологии, в качестве шлюза по умолчанию используются коммутаторы Cisco Catalyst ws-c4948 (sw3-00 и sw3-01) - они же являются ядром сети. Приоритет sw3-00 выше чем sw3-01.

Для уровня доступа используются коммутаторы Cisco Catalyst 2960-24 (sw2-01 и sw2-02).

Для доступа в глобальную сеть используется маршрутизатор, настройки которого опущены. IP-адрес маршрутизатора является 192.168.11.254. В качестве маршрута для доступа сети Vlan 129 и Vlan 144 указан адрес виртуального маршрутизатора Vlan1.

View the embedded image gallery online at:
https://itcrowd.top/hsrp#sigProIde5d762424b

Различия в настройках коммутаторов sw3-00 и sw3-01 заключается в разных IP-адресах на Vlan-интерфейсах:

  interface Vlan 1 interface Vlan 129 interface Vlan 144
sw3-00 192.168.11.252 192.168.129.253 192.168.144.253
sw3-01 192.168.11.251 192.168.129.252 192.168.144.252

Для каждого Vlan-интерфейса на коммутаторах sw3-00 и sw3-01 указан адрес виртуального маршрутизатора который используется в качестве шлюза по-умолчанию:

interface Vlan 1 interface Vlan 129 interface Vlan 144
192.168.11.253 192.168.129.254 192.168.144.254

Коммутаторы доступа подключены через магистральные (Trunk) порты как к sw3-00 так и к sw3-01, в которых разрешены Vlan 129 и Vlan 144 .

На всех коммутаторах активирован протокол защиты от петель на канальном уровне RPVST:


spanning-tree mode rapid-pvst

Настройка интерфейсов на sw3-00:


interface Vlan1
ip address 192.168.11.252 255.255.255.0
standby 1 ip 192.168.11.253
standby version 2
standby 1 priority 200
standby 1 preempt
!
interface Vlan129
ip address 192.168.129.253 255.255.255.0
standby version 2
standby 1 ip 192.168.129.254
standby 1 priority 200
standby 1 preempt
!
interface Vlan144
ip address 192.168.144.253 255.255.255.0
standby version 2
standby 1 ip 192.168.144.254
standby 1 priority 200
standby 1 preempt

Настройка интерфейсов на sw3-01:


interface Vlan1
ip address 192.168.11.251 255.255.255.0
standby 1 ip 192.168.11.253
standby version 2
standby 1 preempt
!
interface Vlan129
ip address 192.168.129.252 255.255.255.0
standby 1 ip 192.168.129.254
standby version 2
standby 1 preempt
!
interface Vlan144
ip address 192.168.144.252 255.255.255.0
standby 1 ip 192.168.144.254
standby version 2
standby 1 preempt

Проверка работоспособности выполняется командой:


show standby

 

Добавить комментарий


Logo